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 Introduction 
 
The Autodesk® FMDesktop database and shared resources must be installed on a server if more 
than one computer will be using FMDesktop components.  Supported Database platforms in the 
networked environment are: 
 

 Microsoft Access 
 Microsoft Access linked to SQL Server 
 Microsoft Access linked to Oracle 

  
The Facility Manager Resource Folders contain drawings, graphics, documents, reports, and other 
resources shared by all of the FMDesktop components.  The folders are: 
 

 DWF – Stores space plans and plan views 
 Graphics – Stores occupant, equipment, and other record-related pictures 
 Markups – Stores drawing markups 
 Project Documents – Stores project and other associated documents 
 Reports – Stores On-Line Reports for collaboration and publishing 

 
To install FMDesktop shared resources for the first time, skip to the section titled, Installing the 
FMDesktop Resources Folder and Database for the First Time, after assuring that your 
Hardware and Software meet the requirements in the following section. 
 
If you are upgrading an older version of FMDesktop, proceed to the section titled, Upgrading 
the FMDesktop Database, after assuring that your Hardware and Software meet the 
requirements in the following section. 
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 Server Hardware and Software Requirements 
 
The server must be compatible with the database platform you choose.   For details concerning 
hardware and operating system requirements, consult your Microsoft Access, SQL Server or 
Oracle documentation. 
 
If you are installing Facility Request on the same server as the database, please consult the 
Facility Request installation documentation for server hardware and software requirements. 
 

MS Access (required) 2003 or 2007  

SQL Server (optional) 2000 or 2005  

Oracle (optional) 10g or 11g  
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 Upgrading the FMDesktop Database 
If you are installing FMDesktop for the first time, skip to the section titled Installing the 
FMDesktop Resources Folder and Database for the First Time.   

Steps to Upgrade 
1. Upgrade your Microsoft Access Middleware database. 
 
If you are using Oracle or SQL Server 
2. Upgrade your Database 
3. Re-link the Microsoft Access database to the Oracle or SQL Server database.  

 

1. Upgrade Your Microsoft Access Middleware Database 
If you are using a shared Microsoft Access implementation, you can skip this guide and 
proceed directly to installing Facility Manager.  The next time a user runs Facility 
Manager, it will detect that your shared database needs upgrading and automatically 
upgrade it. 

1. If you are upgrading SQL Server or Oracle, follow the steps below to update your 
existing Microsoft Access middleware database. To upgrade from a previous version of 
FMDesktop, edit the blue portion of the following command to reflect the correct location 
and file name of your existing FMDesktopMiddleware.mdb file. 

FMDUpgrade.exe Global "C:\Program Files\FMDesktop\Facility Manager 2009\ 
FMDesktopMiddleware.mdb" 

From a Command Prompt, navigate to the “Middleware Updater” folder on the Facility 
Manager Oracle or SQL installation CD and run your edited command. 

2.  Proceed to the next step. 

2. Upgrade Your Database 

SQL Server 2000 
The following instructions require that you have SQL Server up and running, have SQL 
Server Enterprise Manager running, and have a basic knowledge of SQL Server 
management concepts. 

1. Make a complete backup of your SQL Server database. 

2. Verify that you are running SQL Server FMDesktop version 6.5 or later.  If you are on 
an older version, please upgrade to 6.5 first and then return to follow these 
instructions. 

3. Open SQL Server Enterprise Manager and navigate to Databases. 

4. From the Databases tree, select the FMDesktop database (FMData). 

5. On the SQL Server Enterprise Manager toolbar, select Tools>SQL Query Analyzer. 

6. On the SQL Query Analyzer toolbar, select File>Open. 

7. Use SQL Server Management Studio to open the appropriate update scripts. If your 
existing installation is version 6.5, open the scripts Update_6.5_To_7.1.sql and 
Update_7.1_To_2009.sql. If it is version 7.0, open the scripts Update_7.0_To_7.1.sql 
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and Update_7.1_To_2009.sql. If it is version 7.1, open the script 
Update_7.1_To_2009.sql.   

8. Run the script by pressing F5 or clicking the Execute button. 

9. Confirm that the script completed without errors or warnings. 

10. Skip to step 3, Re-link Microsoft Access to SQL Server or Oracle. 
 

SQL Server 2005 
The following instructions require that you have SQL Server up and running, have SQL 
Server Enterprise Manager running, and have a basic knowledge of SQL Server 
management concepts. 

1. Make a complete backup of your SQL Server database. 

2. Verify that you are running SQL Server FMDesktop version 6.5 or later.  If you are on 
an older version, upgrade to 6.5, and then return to follow these instructions. 

3. Double click the update script. If your existing installation is version 6.5, open the 
scripts Update_6.5_To_7.1.sql and Update_7.1_To_2009.sql. If it is version 7.0, open 
the scripts Update_7.0_To_7.1.sql and Update_7.1_To_2009.sql. If it is version 7.1, 
open the script Update_7.1_To_2009.sql. The scripts will be opened by Microsoft 
SQL Server Management Studio. 

4. Change the default database “master” to the FMDesktop database from the database 
drop-list. 

5. Click the Execute button from the right of database drop-list. 

6. Confirm that the script completed without warnings. 

Oracle 
The following instructions require that you have Oracle up and running with a compatible 
ODBC driver and that you have SQLPlus or iSQLPlus installed from a Windows 
Workstation. You must also have a basic knowledge of Oracle Server management 
concepts. 

 
1. Make a complete backup of your Oracle database. 

2. Verify that you are running Oracle FMDesktop version 6.5 or later.  If you are on an 
older version, please upgrade to 6.5 first and then return to follow these instructions. 

3. Log into ORACLE SQLPlus or iSQLPlus with a user who has permission to create a 
user, tables, views, sequences, and triggers. 

4. Navigate to the Scripts folder located on the Facility Manager Oracle installation CD.  

5. If your existing installation is version 6.5, run the scripts Update_6.5_To_7.1.sql and 
Update_7.1_To_2009.sql.  You can open the scripts and copy them to the SQLPlus or 
iSQLPlus session that is open. Run the scripts. Confirm that the scripts completed 
without warnings. 

6. If your existing installation is version 7.0, run the scripts Update_7.0_To_7.1.sql and 
Update_7.1_To_2009.sql. You can open the scripts and copy them to the SQLPlus or 
iSQLPlus session that is open. Run the scripts. Confirm that the scripts completed 
without warnings. 
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7. If your existing installation is version 7.1, run the script Update_7.1_To_2009.sql. 
You can open the script and copy it to the SQLPlus or iSQLPlus session that is open.  
Run the script. Confirm that the script completed without warnings. 

 

3. Re-link Microsoft Access to SQL Server or Oracle 
After all server and middleware updates have been successfully completed, we 
recommend re-linking your Microsoft Access database to your SQL Server or Oracle 
database.  To do this, proceed to the section at the end of this document titled, Linking 
Microsoft Access to SQL Server or Oracle. 

 



 

8 

 Installing the FMDesktop Resources Folder and 
Database for the First Time 

Steps to Install 
1. Create the Resources folder and the Microsoft Access Middleware database 
2. Install a SQL Server or Oracle database and create a DSN 
3. Link the Microsoft Access database to the Oracle or SQL Server database.  

 

1. Create the Resource Folder and the Microsoft Access 
Middleware Database 
1. To share your resource folders and database, create a new folder on your server 

(e.g. c:\FMDesktop).  Set the permissions on this folder so that Facility Manager 
users will have full control of the folder. 

2. If you are using a Microsoft Access only network implementation, you have 
completed this portion of your installation.  You will create your shared database 
during the link process after Facility Manager is installed.  If you wish to share the 
sample database, you can copy the Sample Data folder from your CD up to your new 
folder.  Close this guide and proceed to installing Facility Manager.    

3. Regardless of whether you are using SQL Server or Oracle, you must install the 
Microsoft Access middleware database on your server.  Take the following steps to 
install the database: 

a. Copy “FMDesktopMiddleware.mdb” from the “DataSourceMiddleware” folder 
on your Facility Manager CD to the new folder (e.g. c:\FMDesktop).  

b. Right-click on FMDesktopMiddleware.mdb in its new location, and check the 
Security settings under Properties to ensure that all Facility Manager, Facility 
Link, Facility Request, and Facility Web Publishing Wizard users have full 
control of the file.  

2. Install Database & Create a DSN 

SQL Server 
The following instructions require that you have SQL Server up and running, have SQL 
Server Enterprise Manager running with a compatible ODBC driver, and have a basic 
knowledge of SQL Server management concepts. 

Running FMDesktop on SQL Server requires that a SQL Server database be installed on 
either the same server as the shared resources or on a separate server.  The SQL Server 
database must be made accessible to users via a DSN. The following instructions will 
help guide you through the process of updating or creating a SQL Server database, and 
creating a DSN for access to the database. 
 
1. From the Facility Manager SQL installation CD, copy the SQL folder to your server. 

 
Note: The location you select for this file will be used by SQL to maintain backup 
information and historical data. 
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2. Open SQL Server Enterprise Manager and navigate to Databases (for SQL Server 
2000) or Open SQL Server Management Studio (for SQL Server 2005). 

3. Right-click on Databases and select All Tasks>Restore Database (for SQL Server 
2000) or Right-click on Database > Restore Database (for SQL Server 2005). 

4. On the Restore database form, in the Restore as database field, enter FMData.  

 
Note: Using “FMData” as the database name ensures a clean link through the DSN to 
the end users. 
 

 
5. On the Restore database form, select From device. 

6. Click Select Devices. 

7. On the Choose Restore Device form, click Add. 

8. On the Choose Restore Destination form, click the ellipse button (…) and navigate to 
the SQL folder on your local or network drive. 

9. Select the FMDataSQL file, and click OK. 

10. Highlight the device name you just added, for example, C:\SQL\FMDataSQL, and 
click OK. 

11. On the Restore database form, select Restore backup set, select Database-complete 
(for SQL Server 2000) or Select the backup sets to restore form and select the 
checkbox corresponding to the FMDesktop database (for SQL Server 2005). 

12. On the Options tab, verify the logical file name, and confirm that the correct location 
is displayed for Move to physical file name. 

13. Under Recovery completion state, select Leave database operational - No additional 
transaction logs can be restored, and click OK (for SQL Server 2000), or select Leave 
the database ready to use by rolling back uncommitted transaction. Additional 
transaction logs cannot be Restored (for SQL Server 2005). 

14. SQL Server restores the FMData database to your server.  
A message displays to notify you when the restore process is completed successfully. 

15. Click OK. 

 

Create a SQL Server DSN 
 
The FMDesktop SQL edition relies on a system DSN (Data Source Name) to provide 
connectivity between the Microsoft Access database and the SQL server database.  
During Facility Manager and Facility Link installation, the same DSN must be created on 
each user’s machine and may be configured, if desired, to include the user’s specific 
Login ID and Password. Make note of your DSN settings for use later.  Though the 
process of creating a system DSN varies slightly depending upon specific operating 
systems, the steps outlined below will help to guide you through the process of creating 
a system DSN. 
 
1. On the Windows Start menu, locate and select Control Panel. 

2. On Windows XP or NT, select Administrative Tools. 
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3. To open the ODBC Data Source Administrator, select Data Sources (ODBC).  

4. Click the System DSN tab, and click Add.  

 
Note: File DSNs are not supported by FMDesktop. You must use a System DSN to 
ensure that all FMDesktop applications work as designed. 
 

 
5. On the Create New Data Source form, select SQL Server from the list of available 

drivers, and click Finish. 

6. On the Create New Data Source to SQL Server form, for Name, enter FMDataSQL.  

 
Note: If you use a DSN other than FMDataSQL, the instructions in the section 
titled, “Link Microsoft Access to SQL Server or Oracle” must be followed every time 
a new database is created in the Facility Manager application before a connection 
can be made. 
 

 
7. For Description, enter a description. 

8. For Server, enter the name of the computer that hosts the “FMData” SQL Server 
database. 

9. Click Next. 

10. You may adjust Authentication and Configuration settings if needed. 

11. Click Next. 

12. Select Change the default database to. 

13. Select FMData from the list of available databases.  

 
Note: If the “FMData” SQL Server database was restored under another name, 
select that name from the list of available databases. 
 

 
14. Click Next. 

15. You may adjust Language and Other Option settings if needed. 

16. Click Finish. 
The ODBC Microsoft SQL Server Setup form is displayed. 

17. Click Test Data Source. 
“Test Completed Successfully” should display in the Test Results window. 

18. Click OK on all open DSN configuration windows. 

19. Click OK to complete set up. 

20. Click OK to exit ODBC Data Source Administrator. 

21. Proceed to Link Microsoft Access to SQL Server or Oracle. 
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Oracle 
The following instructions require that you have Oracle up and running with a compatible 
ODBC driver and that you have SQLPlus or iSQLPlus installed from a Windows 
Workstation. You must also have a basic knowledge of Oracle Server management 
concepts. 

 
 
Note: Each user must have access and permissions to the server that hosts the 
Oracle database. 
 

 
Running FMDesktop on Oracle requires that an Oracle database is installed on either the 
same server as the shared resources or on a separate server.  Additionally, the Oracle 
database must be made accessible to Facility Manager and Facility Link users via a DSN. 
The following instructions will help guide you through the process of updating or creating 
an Oracle database and creating a DSN for access to the database. 

 
1. Log into ORACLE SQLPlus or iSQLPlus with a user who has permission to create a 

user, tables, views, sequences, and triggers.  

2. Navigate to the Scripts folder on the Facility Manager Oracle installation CD. 

3. Copy the script named FMDataOracle.sql to your local hard disk and open it. 

4. Verify the script for default user/password, and then execute the script. 

5. Confirm that the script completed without errors or warnings. 

6. Continue with the next section to Create an Oracle DSN on your server to provide 
connectivity between the Microsoft Access middleware and the Oracle database. 

Create an Oracle DSN 
The next step is to create a system DSN (Data Source Name) to provide connectivity 
between the Microsoft Access middleware database and the Oracle database you just 
created. During Facility Manager and Facility Link installation, the same DSN must be 
created on each user’s machine and may be configured, if desired, to include the user’s 
specific Login ID and Password. Make note of your DSN settings for later use.  Though 
the process of creating a system DSN varies slightly depending upon specific operating 
systems, the steps outlined below will help to guide you. 

 
Note: It is recommended that you download and install the appropriate Oracle Client 
software as provided by Oracle prior to performing the following steps. 
 

 

1. On the Windows Start menu, locate and select Control Panel. 

2. On Windows XP or NT, select Administrative Tools. 

3. Select Data Sources (ODBC) to open the ODBC Data Source Administrator. 

4. Click the System DSN tab, and click Add. 
The Create New Data Source form is displayed. 
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Note: File DSNs are not supported by FMDesktop. You must use a System DSN to 
ensure that all FMDesktop applications work as designed. 
 

5. On the Create New Data Source form, select the Oracle ODBC Driver as provided by 
Oracle from the list of available drivers, and click Finish. 

The Oracle ODBC Driver Setup form is displayed. 

6. In the Data Source Name field, enter FMDataOracle.  

 
Note: If you use a DSN other than FMDataOracle, the instructions in the section 
titled, “Link Microsoft Access to SQL Server or Oracle” must be followed every time a 
new database is created in the Facility Manager application before a connection can 
be made. 
 

 
7. For Description, enter a description. 

8. For TNS Server Name, select the service which is configured in Net Configuration 
Assistance of Oracle Client. 

9. For User ID, enter your user name (or the default name in the install script is 
FMData). 

10. Click the Test Connection button, enter your password (or the default password in 
the install script is ORACLE), and then click OK. 

11. Click OK to complete set up. 

12. Click OK to exit ODBC Data Source Administrator. 

13. Proceed to the next section. 

 

3. Link Microsoft Access to SQL Server or Oracle 
After updating or creating the SQL Server or Oracle database and a DSN, you must link 
your Microsoft Access database to your SQL Server or Oracle database: 
 
1. Open the FMDesktop Microsoft Access Database in your server folder using MS 

Access 2003 or higher. 

2. On the Tools menu, select Database Utilities>Linked Table Manager. 

3. On the Linked Table Manager form, click Select All. 

4. In the lower-left corner of the Linked Table Manager form, select Always prompt for 
new location. 

5. Click OK. 
The Select Data Source form is displayed. 

6. Click the Machine Data Source tab to display a list of available DSNs. 

7. From the list of available DSNs, select the DSN of your Oracle or SQL Server 
database.  

8. Click OK. 
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Microsoft Access will attempt to connect or reconnect each table to the SQL Server or 
Oracle database using the settings defined in the DSN.  
 

 
Note: If this operation fails, or you continue to receive ODBC connection errors 
when opening a table, you can try to link one table at a time.  If that doesn’t work, 
you will need to redefine your DSN connection as outlined above. 
 

 
Upon successfully linking Microsoft Access to SQL Server or Oracle, you have completed the 
shared resource FMDesktop installation.  Individual users can use the Facility Manager 
Installation Guide to install Facility Manager, create a DSN, and link Facility Manager to the 
Microsoft Access middleware database. 


